Bought an OUYA online, HELP

Bought an OUYA online and it was factory reset. Stuck on Network page. it logs into my wifi but wont find server. Because it was factory reset i can not access the settings there for i can not get MTP turned on, there for my PC will not see my OUYA.

Ive looked for OUYA USB drivers but can not find anything thats not malware or deceiving. All i want to do is put my IPTV and a couple emulators on it.

Ive tried all kinds or cords, USB OTG box but it still didnt see it. thats when i came to the conclusion it must be the drivers. I am pretty new to this stuff. i mean ive flashed an original xbox and some phones back in the original xbox days. But recently bricked a expensive Samsung tab caused by my old ways. This time im asking for help. One brick caused by me is enough lol. I am 53 so im no young gun know it all either lol.

Im just hoping someone can help an old fart get his tv and emulators on a OUYA. Thanks in advance for any and all help.


Hello ,
This movie helped me
Flashing the OUYA with i12bretro Image v3.0 - YouTube
you can also use the help from this forum topic : How to setup an OUYA the easy way - Tutorials - OUYA World

1 Like

After further review drooling on a field says I’m a knob :rofl:. My 15 year old son said " Dad would you try this cable please? I know you got that box hooked up but please humor me." It was just that. Yes the easy setup is how I got in. Plus gave me root.

Question, after I did all that and did the sign in it goes to the home page but then goes back to the sign in page. Am I doing something wrong? I tried to reuse my original DNS but I can’t sign in with the original DNS. Says a network error occured! (Unable to resolve host “”: no address associated with hostname)

check if you have the file in the root directory, also check what version of ouya you have if you can check the software versions, it seems to me that you have an older version and it would require an update. Send screenshots if you can, besides, did you upload the image or did you use a script in power shell?

I used the script in power shell.

I did figure out if you just use a username to login with not an email it’s fine.

I’m going to add some pics as I’m curious to know if I have the updated firmware.

Also I now also see I can not get on the web.

you have an old version of the software, it will be easiest to upload the image from this friend from yt

Where can I get a copy from?

[quote=“MtBeer, post:10, topic:820”]
here can I get a copy from?
[/quote] - Dysk Google

full steps :

Flashing the OUYA with i12bretro Image v3.0

Also when I send the command to disable driving signing checks I get a some kind of error not allowed. I’m guessing that’s why it won’t load the driver?

Not sure how I did it but it looks like I did :grin:.

Thanks for all your help. Love this system.