I can't get any app/game to finish 'installing...' successfully

[1-sentence summary]
I can’t get any app/game to finish ‘installing…’ successfully

[What should be happening]

Game or app should install successfully and be available in Play area

[What is happening]

  1. Select an game or app from ‘Discover’
  2. Select any game or app
  3. Select ‘free download’. Download is successful and ‘Installing…’ process starts but never finishes (Just keeps showing ‘Installing…’).
  4. Check Play area and notice no app or game is shown

[What I’ve tried already]
Tried many games (both free and available for purchase) and apps. All fail to install.

Any suggestions would be appreciated. Thanks in advance. Billy

The only way to get to the bottom of the issue is to obtain system logs from the ouya.

You need adb installed on your PC and then run adb logcat > file.txt. (ConnectYa also has the feature to take logs). Upload this file here. (maybe zip it first, that will make the file much smaller).

Thanks for reply.

zipped log file

Here we have the problem:

D/HTTP    (  578): Response 53: GET /api/v1/apps/392d4d15-2a2c-443d-8b77-2b42a327d491/download?auth_token=00702342-0000-1111-2222-c3e1500cafe1 HTTP/1.1 (status: HTTP/1.1 200 OK)
D/s       (  578): [{
D/s       (  578):     "app": {
D/s       (  578):         "fileSize": 19454789,
D/s       (  578):         "version": "392d4d15-2a2c-443d-8b77-2b42a327d491",
D/s       (  578):         "contentRating": "9+",
D/s       (  578):         "downloadLink": "http://statics.ouya.world/ia/ouya_com.loadupgames.brickbreakerpremium_1.5.0/Brick%20Breaker%20Premium_1.5.0_com.loadupgames.brickbreakerpremium.apk"
D/s       (  578):     }
D/s       (  578): }
D/s       (  578): ]
D/AppDownloadService(  578): Updating download queue
D/AppDownloadService(  578): Started download -9223372036854775765 [43]
D/DownloadUtils(  559): Getting completed download info for: -9223372036854775765
D/DownloadUtils(  559): Found download info
D/DownloadUtils(  559): Using DownloadManager's filename: /mnt/usbdrive/com.loadupgames.brickbreakerpremium.apk
I/ApkDownloadReceiver(  559): Download complete for com.loadupgames.brickbreakerpremium
W/AppsUtils(  559): File size doesn't match: packageName=com.loadupgames.brickbreakerpremium expectedSize=19454789 realSize=3978

So it tries to download the following file:


But it only gets 3 kiB instead of 12 MiB of data.

The question is why.
Can you download that file in your browser?
Do you have some kind of network filter that requires devices to confirm some WiFi login page?
What happens when you open http://statics.ouya.world/ in the ouya’s browser?

It has now strangely just started working. i.e. Successfully downloading and installing all the games I’ve tried so far. I’ve changed nothing on my network. Maybe something my ISP has done?

Many thanks for your help.