Ouya SDK: Unity input joysticks do not work when the Ouya SDK is installed

Reposted from the The OUYA Lives! Winter 2019 OUYA Jam Community Post I had made…

Took a day longer than i had hoped but i finally got the Ouya version of Crime in Progress to work with controller support on Ouya.

After racking my brain i found this…

Ouya SDK: Unity input joysticks do not work when the Ouya SDK is installed

When the Ouya Everywhere SDK is installed in the project, it interferes with Unity’s input system on Android builds preventing any joystick axes or buttons from working. At present, there is no known solution to make Unity input work on Android when the Ouya SDK is installed.

Sure enough i was using the Ouya SDK, once removed, controller support that worked in the Unity editor worked on the Ouya.

Just a heads up to anyone that may have faced the same issue.

Oh the source for this information came from here:

1 Like

Not much use for the ODK now, anyway.

Thank’s @sketche99 .

@sketche99 which ODK do you have? Is a recent ODK something we would want to make available here since it seems to be hard to find a recent one. I happened to find in my laptop downloads folder a copy of v2.0.1 which I think is one of the last versions. I’ve seen some pages that seem to reference v2.1.0 and even a v2.1.0.3, but I haven’t found downloads for either, or even for one as recent as the one I happen to have.

I was using v2.1.0.3 from the Ouya Github:


Perfect. I had found this repo before, but I had discredited it because I was expecting something a bit different (the 2.0.1 version I have only has the core android stuff, not the all the stuff for the other engines and the ouya-sdk.jar was right in the root). After actually digging around this is exactly what I was looking for, thanks!

1 Like