Plex, Kodi, VLC, Netflix, and Prime in 2021

Hi OUYA World, my first post!

I just recently re-fired up my OUYA and wanted to see what it could still do for streaming. I couldn’t find any threads in other forums that gave recent (within the last 5 years) discussions about where to get usable versions of the titled apps so I’m compiling a quick list below as a shared reference for people.

1) Plex (2.5/5 Stars) - I had an old version of Plex for OUYA from the discover store that I tried first, but even though I was still logged in with a plexpass account, it didn’t load any content at all (local or online). After I rooted the little guy and pointed to the new server (thank you OUYA Saviors Project) I uninstalled Plex for OUYA and reinstalled it again from the new server and found that it was a different (newer) version. Unfortunately, this one gave a “couldn’t reach myplex” error every time I tried logging in. I then looked up the historical builds of plex for the last released version that supported android 4.1 and sideloaded that. It let me sign-in and looked like it would work, but crashed shortly after if I tried to switch it the “tv optimized mode”. Leaving the sideloaded Plex in the “touch” mode seems to be stable so far, although the playback quality definitely leaves something to be desired and navigation is a bit clunky (but it works!!).

Plex 6.17.1 apk link:
https://www.apkmirror.com/apk/plex-inc/plex/plex-6-17-1-5294-release/plex-6-17-1-5294-3-android-apk-download/

2) Kodi (5/5 Stars) - I ditched the XBMC for OUYA app from the Discover store a long time ago for a sideloaded version of Kodi 14 and it was a HUGE improvement for playback. After I found the newer Plex build, I also found the link for the last Kodi build that supported Android 4.1. It installed fine and even carried over all my old setup folders and network links. Playback quality is still awesome and appears stable, but I haven’t used it much yet.

Kodi 14.2 apk link:
https://www.apkmirror.com/apk/xbmc-foundation/kodi/kodi-14-2-5-release/kodi-14-2-android-apk-download/

3) VLC (4/5 Stars) - I’m pretty sure that the original VLC for OUYA app was half-baked to begin with and they had the intention of finishing it, but clearly never got around to it (and I don’t blame them). I never could figure out how to navigate playback once to start a movie (pause, forward, back). Anyhow, as part of the rooting this week I installed the google play store and installed the current VLC version from there. Worked like a treat!! Far better interface and it even automatically pulled in my network shares. It lost 1 star only because the playback isn’t as smooth as Kodi.

4) Netflix (4/5 Stars) - I used to have the netflix app sideloaded from the amazon store, but it wasn’t working anymore. Again, I found the latest historical version that supported Android 4.1 and sideloaded it. It’s also optimized for touch, but is way better than the old one from the amazon store and also could still connect to the netflix servers.

Netflix 3.16.6 apk link:
https://www.apkmirror.com/apk/netflix-inc/netflix/netflix-3-16-6-build-5382-release/netflix-3-16-6-build-5382-android-apk-download/

5) Amazon Prime (3.5/5 Stars) - Amazingly the version of Prime currently in Google Play actually offers native supports for Android 4.1, so this one was straight forward (after rooting and installing Google Play). Lost one star for playback quality, and a half star for the clunky touch interface quirks.

NOTE: These versions are best applied to the stock OS. If you’re installing a later version of Android (i.e. cyanogen 11 running 4.2), you can find more recent compatible builds of Plex and Kodi. Netflix went straight to Android 5.0 for the next build.

Sorry for the novel… TLDR, go to the links, download to USB, and sideload using FilePwn.

1 Like

Just want to add: Download at your own risk

Unverified links like this aren’t always trust worthy.

But good right up anyway.

1 Like

Thank you very much for this post. Unfortunately, there is a disadvantage in the Plex version you mentioned… if you don’t have a Plex Pass, it’s not useful. You can’t even stream your own media from your down Plex server :frowning:

I used Plex on OUYA for years and it was working fine right into the beginning of 2021, when I added some content to my server and watched it on my OUYA - the native client never asked for a Plex Pass for full functionality.

Maybe there is a different version around that works better?

I’m also trying to Install Amazon Prime Video. The app installs and can be launched, but I have no Playback. Every time I try to play something (even free trailers), it returns to the description screen of the video. Am I forgetting something?

Good add, I should have included that in the original post. I guess I kinda figured most people in this community would take that as a given.

Weird quirk, now I’m kinda interested in trying to create a new non-plexpass account and log in with that to see what happens on mine.

I’m assuming that you’re also logged in? I literally just downloaded/installed from Google Play, logged in, and started playing Amazon Prime content. There were some fiddly bits using the touch-pad on the controller to select items, but no special hoops to jump through.

Yes indeed. On my TV, you don’t need the pass, just like on OUYA back then. On iOS devices, you can make a single in-app-purchase to unlock this Feature. But on Android, they demand the pass… :frowning:

Yes of course, I use Prime Video on TV, iPhone and Shield. Will try again later this week.