Retroarch on uoya store don't work

[1-sentence summary]

[What should be happening]

[What is happening]
I purchased an ouya some time ago, I managed to connect it and use it correctly both with the original games and with the emulators (retroarch present on the ouya store). about a month ago, trying to enter retroarch it gave me an error message.

[What I’ve tried already]
I thought it was due to a system update, but when I checked the ouya it didn’t have any updates to do. I tried to see if there were retroarch updates and indeed there were but it wouldn’t let me download them. I uninstalled retroarch but when I try to download it again it doesn’t install it anymore (an error message appears that doesn’t specify the problem).
I tried to perform a factory reset on ouya, reinstalled the software and reconnected uoya to the community server; I went back to the ouya store and tried to install retroarch again but nothing… the same generic error as before… I don’t know what to do anymore, does anyone have any information about it?

The game page RetroArch - OUYA game links to the server:

This file does not exist. I’ll ask @Szeraax if he could start a sync.

The problem has been fixed.

thank you very much!