How to bypass account login/firmware update page

Requirements

  • USB Micro cable to connect OUYA to PC.
  • DNS host override settings that you can change on your router (See " Why Do I Need to Change My DNS Settings?!" for more details)
  • Most people find that using an ethernet cable to connect OUYA to internet is far better than Wifi.

Connecting to the community server

  1. OUYA needs to be powered on
  2. Connected to your computer
  3. Needs to be showing up as an MTP device (install drivers if it doesn’t): unknown
  4. When you can view the contents of the internal storage like this: unknown2
  5. Go get my ouya_config.properties (103 Bytes) file and drop it into the “Internal storage” drive
  6. Login to your router
  7. Add a DNS host override for devs.ouya.tv to 45.79.49.220 and status.ouya.tv to 45.79.49.220
  • This is typically done on your routers “WAN” page or from a DNS settings page
  1. Go back to your OUYA mouse/controller/keyboard
  2. Reboot your OUYA for good measure
  3. Get past update screen (if needed) and on the Account page, select “Existing account” and type in anything for the username and password
  4. Change your DNS setting back to what it was
  5. Apps should begin working, if you have any issues launching your apps, you can try disconnecting from the internet (ethernet and wifi) to force your OUYA into standalone mode

Disconnecting from the community server

If you don’t want to use the community server anymore, simply delete the file that you dropped into the OUYA Internal Storage and it’ll begin trying to contact the Razer server again.

Why Do I Need to Change My DNS Settings?!

The OUYA has a hardcoded check to lookup the address devs.ouya.tv (which doesn’t exist anymore). You must use one of the solutions below to trick it into thinking that it’s connected to devs.ouya.tv. Check em:

Use DNS host overrides

DNS host overrides allow you to just add a couple direct mappings without changing your whole DNS system (not all routers support this, but its a GREAT option):
devs.ouya.tv 45.79.49.220
status.ouya.tv 45.79.49.220

Then reboot your OUYA and try it again.

Use ADB shell to edit hosts file directly:

Use adb shell, su, mount r/w, then edit /etc/hosts. Requires that you are familiar with cmd, adb, and linux.
ADB - https://dl.google.com/android/repository/platform-tools-latest-windows.zip
adb shell
su
mount -o rw,remount -t ext4 /dev/block/platform/sdhci-tegra.3/by-name/APP
echo "45.79.49.220 devs.ouya.tv" >> /etc/hosts
echo "45.79.49.220 status.ouya.tv" >> /etc/hosts

Then reboot your OUYA and try it again.

Edit OUYA hardware DNS server for just itself:

This is done by editing the networking settings to use a static IP and type in all the same info, except change the DNS server to 45.79.49.220. Once you login, you have to go and change the network settings back to DHCP like normal.

Then reboot your OUYA and try it again.

Poison your DNS queries

This is … what you use if you mostly don’t want to deal with any of the above and you feel like showing some power. This method uses Kali Linux, but you can use any linux you want if you put Ettercap on it.

  1. Download Kali Linux (I prefer getting “Live x64”)
  2. Run it on a computer (VM or physical)
  3. Edit /etc/ettercap/etter.dns
  4. Add entry devs.ouya.tv A 45.79.49.220 anywhere in the file
  5. Add entry status.ouya.tv A 45.79.49.220 anywhere in the file
  6. Save and close
  7. Run: ettercap -i eth0 -T -q -P dns_spoof -M ARP
  8. Reboot your ouya and try it now

Then laugh your head off cause this method is totally overkill, but it works. Src: https://pentestmag.com/article-fun-ettercap/

Wrapping up

You just need to get the OUYA to see that devs.ouya.tv and status.ouya.tv are located at 45.79.49.220. You can do it!

Getting Help / I’m Stuck!

If you need help with these instructions, you can use the forum chat (see the Megaphone icon? Maybe in the bottom left, maybe at the top), chat us in discord at https://discord.gg/Sdhhuw2, reply here, or post in #help.

Make sure ouya_config.properties is in the root of the MTP drive, located at /sdcard/ouya_config.properties if using adb to create the file.

Also, CWeiske has some alternate instructions that may help you out: http://ouya.cweiske.de/#usage

2 Likes

What kinda drivers do i download???

Honestly, it worked for me without drivers. If it doesn’t just work for you automatically, you’ll need some “android” related drivers that allow your computer to see the OUYA device as shown in screenshot 1.

Is that what sdk is?

Ya. And hopefully that works easy for you :slight_smile:

Thanks really appreciate it

help it doesnt work still, ive tryied your walkthrough and seen other videos it still doesnt wanna connect

Check out the chat I sent you. I think that if you can’t get it working using ethernet and a couple more reboots, you’ll have to flash it to the latest firmware. Alternatively, we could try out another way of auto-upgrading your firmware, but you’d have to wait a week or so for me to even be ready to test it out.

http://devs-ouya-tv-prod.s3.amazonaws.com/ota/RC-OUYA-1.2.1427-r1_ota.zip

@szeraax Couldn’t people just use a thumbdrive to copy the file onto and then use filepwn or es file explorer, etc, to copy the file to their OUYA’s internal storage?

Thus negating the need to connect the OUYA direct to PC.

Nope. They can’t get past the login screen. :slight_smile:

Ohhhhh right. I didn’t put that together. I’ve been sick as a dog the past week, my brain is mashed potatoes. :face_with_thermometer:

This worked great, thanks! Few notes, maybe handy for other users:

  • The first time I couldn’t connect the Ouya to my Windows 10 pc. I changed the cable (normal phone cable) to the one of my Shield Tv, and that did the trick. Also, first connect the cable, then boot the Ouya.
  • I also got ‘can’t find ouya.world’ domain errors. Connected the Ouya to the ethernet et voila. Wifi has always been crapy on the Ouya.
1 Like

Warning: Changing the DNS server does not work! The correct solution is the /etc/hosts update some posts below.


If you have a factory reset OUYA the config file is not enough, because OUYA’s setup seemingly does not use the configuration file. You will be stuck at the “network selection” screen.

The solution is to override DNS entries for devs.ouya.tv and status.ouya.tv:

  1. Access your internet router’s web interface

  2. Change the DNS server to 83.169.45.222

    Alternatively, add manual hostname mappings:

    devs.ouya.tv 83.169.45.222
    status.ouya.tv 83.169.45.222
    
  3. Finish the OUYA setup

  4. Change your router’s DNS server back to the original value

I changed my DNS on my router (fritzbox) but I keep getting stuck at the network selection with the same error message. I installed the latest firmware as offered by S-config.

I don’t understand what you mean in step 2. I don’t find this option in my router to set hostname mappings.

Probably I should use your ouya_config.properties:
OUYA_SERVER_URL=http://ouya.cweiske.de
OUYA_STATUS_SERVER_URL=http://ouya.cweiske.de/api/v1/status

Instead of the one from OP:
OUYA_SERVER_URL=http://client.ouya.world
OUYA_STATUS_SERVER_URL=http://client.ouya.world

After modifying the DNS server in your router, you need to reboot the OUYA (or switch to static IP and then back to DHCP, but rebooting is faster).

Overriding single Hostname-IP-Mappings is not possible with a FritzBox.

I don’t know what I do wrong. I rebooted my ouya already 20 times even with pulling the plug.
In my fritzbox i did set the ipv4 DNS to 83.169.45.222. Still the no network error. But I see on the ouya the DNS is still the internal fritzbox dns, so I set this one also to 83.169.45.222. Now on the ouya I see this DNS but it doesn’t work. What should I do? Set the network connection on the ouya to a static ip and give it this DNS?

First check it if works on your computer by running “ping devs.ouya.tv” and “ping status.ouya.tv” on the command line. It should show the IP 83.169.45.222. If not, then your router does not have the new DNS server.

You can try to change the DNS server on the ouya itself, but I do not think that it will work. First keep the network connection on DHCP, note down the ethernet adapter settings (ip, netmask, router) and then switch to static, enter the previous settings and change the DNS server. But that did not work here, so I do not think that it will for you.

I can perfectly ping to http://devs.ouya.tv/ and http://status.ouya.tv/ but the ouya keeps complaining about my internet connection. I have to say, when I ping, it takes a long time before it starts to respond (approx 15 seconds), so maybe the ouya gives up to soon (approx 3sec).

You need to get that down to way below 15 seconds. I also think that’s the problem.


ConnectionTestFragment.CheckForActiveNetwork::run waits for 5 seconds until it sees the connection as failed.

I tested your ouya_config.properties:
OUYA_SERVER_URL=http://ouya.cweiske.de
OUYA_STATUS_SERVER_U.deRL=http://ouya.cweiske.de/api/v1/status

on another ouya and got the message that the connection to http://ouya.cweiske.de is refused.